在Aptana中获取Subclipse以使用最新版本的Subversion

目前通过Aptana的自动插件管理器可用的 Subclipse(1.2.4)版本不适用于最新版本的Subversion。

但是我在Subclipse网站上看到他们拥有1.4.2的Eclipse版本。所以我在我的更新管理器中添加了一个新的远程更新站点。当我试图安装它时,它告诉我我需要 Mylyn 3.0.0 。因此,经过多次搜索,我发现Mylyn 3.0.0并添加了另一个新的远程更新站点<�一个>我的更新经理。然后,当我试图安装它时,它告诉我需要 org.eclipse.ui 3.3.0 或同等功能。

查看Aptana的配置细节,看起来它是针对Eclipse 3.2.2构建的。

有谁知道是否有方法升级Eclipse Aptana的版本,该版本是针对3.3.0构建的?或者如果有其他方法可以使Subclipse与最新版本的Subversion一起工作?

我知道这不一定是一个“编程”问题,但我希望没关系,因为它与编程经验高度相关。

0
额外 编辑
意见: 13

3 答案

我使用了更新URL,并且我安装了JavaHL适配器,Subclipse项目本身 SVNKit适配器测试版。

在这之后它对我来说工作得很好,这对于Linux平台希望它适合你。

0
额外

Subclipse不需要Mylyn,但更新站点包含一个集成了Mylyn和Subclipse的插件。这适用于使用Mylyn的人。就你而言,你只需要在更新对话框中取消选择Mylyn。

Subclipse also requires Subversion 1.5 and the corresponding version of the JavaHL native libraries. I have written the start of an FAQ to help people understand JavaHL and how to get it. See: http://desktop-eclipse.open.collab.net/wiki/JavaHL

0
额外

如果你不打算使用mylyn,只需取消该依赖关系。我对Aptana并不熟悉,但在eclipse中,您可以扩展正在安装的内容,并取消选中不需要的任何内容。

0
额外